20:01:01 <ennael> #startmeeting
20:01:01 <Inigo_Montoya> Meeting started Wed Jan 12 20:01:01 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:01 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:01:02 <erzulie> [ MeetBot - Debian Wiki ]
20:01:05 <ennael> hi all
20:01:12 <Motoko> Good afternoon.
20:01:18 <shikamaru> o/
20:01:27 <farfouille> Good evening ;)
20:01:35 <blino> hi ennael
20:01:37 <Kharec> Good evening
20:01:43 <Ruperto> hello to all
20:01:55 <Renaud_Michel> hi
20:02:03 <philippeM> Good evening
20:02:12 <Xardas008> good morning
20:02:40 <ennael> ok first topic
20:02:57 <ennael> #topic mentoring: review on current process
20:03:25 <ennael> so we started looking for mentors for 2d wave of packagers
20:03:35 <ennael> mainly blogdrake and mandrivausers.de
20:04:05 <ennael> so we have a very small part on wiki page
20:04:42 <shikamaru> http://mageia.org/wiki/doku.php?id=packaging#current_mentoring
20:04:43 <erzulie> [ packaging [Mageia temporary wiki] ]
20:05:02 <ennael> thanks was looking for :)
20:05:10 <brianb__> hi
20:05:11 <ennael> so we have very phew guys here
20:05:26 <ennael> we just need to increase numbers
20:05:51 <Ruperto> i've been contact by a blogdrake person to be my padawan, i did tell him yes but dont know what to do later, i mean the procedure
20:06:11 <ennael> ok
20:06:17 <ennael> can you it on wiki page?
20:06:27 <philippeM> same for me, Iok to mentor, but how ?
20:06:37 <Motoko> What if someone feels they can contribute in the first wave of being mentored? Is there some way to petition?
20:06:42 * Kharec write his name on wiki mentoring page
20:06:49 <Ruperto> yes of course, i will
20:07:11 <ennael> ok so we are back to another topic which is work on mentoring process
20:07:14 <doktor5000> i can mentor some people, but only about packaging, not on the build system stuff
20:07:58 <Motoko> Sorry, I can wait until that topic is set.
20:08:02 <ennael> about mentoring we have shikamaru and Kharec who registered to help writting it
20:08:16 <Kharec> yep
20:08:22 <ennael> will give a hand on it as it's really important for us
20:08:25 <doktor5000> and there definitely should be some mentoring guide and some FAQs that get asked often, no?
20:08:27 <shikamaru> ok
20:08:31 <JohnMS> I'm the same I know how to create RPMs but not the build process.
20:08:35 <gregorybravas> Hi all
20:08:37 <shikamaru> doktor5000: exactly
20:08:47 <Kharec> I'm happy to work with shikamaru again :)
20:08:48 <AL13N> so, is there any current packager who can also mentor others?
20:08:57 <shikamaru> there are already some pages that we could import from the mandriva wiki
20:09:11 <shikamaru> which explains the use of svn, repsys and so on
20:09:13 <ennael> AL13N: it's all in wiki page
20:09:23 <farfouille> http://wiki.mandriva.com/en/Mandriva_RPM_HOWTO
20:09:24 <erzulie> [ RPM packaging tutorial - Mandriva Community Wiki ]
20:09:29 <ennael> Anssi, jq , shikamaru , philippeM
20:09:33 <ennael> for now
20:09:41 <brianb__> how many people in total can mentor and are willing to mentor?
20:09:46 <AL13N> ennael: i meant, is there any others who can offer himself up
20:09:48 <shikamaru> farfouille: well, mentoring supposes you already know how to make RPM I think
20:09:57 <Kharec> and use bs
20:10:00 <shikamaru> and for that we could as well include all the policies
20:10:09 <ennael> ok let's try to put things in order :)
20:10:13 <shikamaru> (I mean, for the first wave)
20:10:23 * doktor5000 is shortly afk
20:11:06 <shikamaru> ennael: yep
20:11:12 <Anssi> I'm mentoring two people at the moment, I can probably mentor at least one more, but it depends quite a bit on the activity of the apprentices (i.e. how much stuff do I need to review)
20:11:35 <farfouille> shikamaru: I was just pointing to mandriva wiki page as something to start with mageia trianing process
20:11:48 * Kharec want to mentor one person at a time, as I write it in the wiki
20:12:07 <brianb__> may i make a suggestion
20:12:18 <shikamaru> I think the first step would be to explain people how to use ssh-agent, because it’s necessary for everything else I can think of
20:12:27 <Kharec> shikamaru: i agre
20:12:28 <Kharec> e
20:12:46 <shikamaru> that could be done in group on #mageia-mentoring IMO
20:12:50 <Kharec> brianb__: sure
20:13:02 <shikamaru> because we could solve the issue of pubkeys once for all
20:13:26 <AL13N> what issue?
20:13:34 <ennael> sorry connection pb
20:13:40 <AL13N> nvm, i think we are getting off topic here
20:13:50 <gregorybravas> my mentoror in mandriva is juan luis baptiste aka maeztro, he said me that he want be my mentor in mageia
20:14:03 <gregorybravas> is posible?
20:14:13 <ennael> yes
20:14:15 <ennael> ok
20:14:21 <ennael> so I sent an email some days ago
20:14:21 <gregorybravas> ok ennael
20:14:29 <ennael> News of the front: first commits and mentoring start
20:14:30 <ennael> mageia/dev
20:14:34 <ennael> oups
20:14:40 <ennael> you have 2 lists inside
20:14:45 <ennael> trainees and mentors
20:15:24 <ennael> given the knowledge level of these trainees would be nice they find a mentor in coming days
20:15:46 <ennael> about mentoring process there are 2 levels
20:15:50 <brianb__> the objective surly is to get as many people up to speed with packaging as soon as posible who dont you have a channel specifically designed to cover this by running  at prescribed times an on channel course for people to understand the processes
20:15:54 <ennael> packaging and use of build system
20:16:26 <Xardas008> whats difficult about the build system?
20:16:28 <brianb__> and the jargan
20:16:39 <ennael> shikamaru: so what we can do is describe a process for these 2 parts
20:16:55 <ennael> Xardas008: it's not difficult but you have to know how to use it
20:17:00 <ennael> what you can do or not
20:17:12 <Anssi> brianb__: well, wouldn't a wiki page suffice for that?
20:17:17 <Xardas008> ok that would be good, and how to log in on it
20:17:27 <brianb__> no because its not interactive
20:17:47 <brianb__> people need to ask questions and get answers
20:17:53 <Anssi> brianb__: well, one can and should ask any questions from the mentor (or generally on irc)
20:17:59 <ennael> #info mentoring process items: packaging howto, build system, jargan
20:18:16 <brianb__> if your assigined a mentor
20:18:27 <AL13N> brianb__: there is a channel #mageia-mentoring (and you need to read stuff before you can ask questions)
20:18:39 <Ruperto> ennael: should be good also a document that explain main differences between MDVA and MGA BS, for the who that comes from MDVA
20:18:56 <brianb__> wel there is not much activity on that channel
20:19:09 <ennael> #info explain main differences between MDVA and MGA BS, for the who that comes from MDVA
20:19:10 <shikamaru> Ruperto: well, from what I tried, there’s a slight difference in how we use SVN
20:19:18 <AL13N> brianb__: i'm always there, and i haven't seen much questions
20:19:26 <brianb__> L13N i think with respect you are missing the point
20:19:59 <Ruperto> shikamaru: yes, i know. but it is good to have it documented somewhere.  It saves many time and efforts
20:20:01 <AL13N> ennael: who will make that document?
20:20:26 <ennael> AL13N: if you follow discussion you would have seen shikamaru, Kharec , me and any other volunteers
20:20:34 <brianb__> the whol process should be documented
20:20:39 <AL13N> ennael: ok
20:20:42 <shikamaru> ennael: summarized in several words, it would boil down to: ssh, svn, repsys, and then packaging process
20:20:52 <ennael> yep
20:21:18 <ennael> ok we will not finalize it tonight but start it in coming daus
20:21:20 <ennael> days
20:21:35 <ennael> and post url as soon as it's started
20:22:11 <brianb__> so is there a list of people who have been asigned to a mentor?
20:22:27 <shikamaru> brianb__: please backlog
20:23:02 <ennael> philippeM, Anssi , will you be able to proofread mentoring process ?
20:23:11 <ennael> could help to have a complete one
20:23:35 <philippeM> ennael: ok for me
20:23:39 <farfouille> Is possible to be trained while not on the list anne sent to the ML ?
20:23:42 <Anssi> ennael: yes
20:23:50 <JohnMS> Have to go, break's done.
20:24:08 <ennael> farfouille: sure but priority will be put on this list
20:24:51 <shikamaru> I will start http://mageia.org/wiki/doku.php?id=mentoring_process
20:24:51 <erzulie> [ mentoring_process [Mageia temporary wiki] ]
20:24:57 <ennael> shikamaru: ok
20:25:01 <Kharec> shikamaru: ok :)
20:25:10 <ennael> #info mentoring process to be written on http://mageia.org/wiki/doku.php?id=mentoring_process
20:25:11 <erzulie> [ mentoring_process [Mageia temporary wiki] ]
20:25:32 <ennael> there was an idea of proposing kind of packaging lesson on IRC
20:25:35 <shikamaru> Kharec: please unlock it
20:25:39 <Kharec> yep
20:25:40 <farfouille> I asked because the list has been published for a week and there is only 4 people currently trained (accroding to the wiki)
20:25:40 <ennael> for very beginner
20:25:40 <Kharec> sorry
20:25:57 <ennael> farfouille: wiki is not up to date
20:26:14 <Xardas008> ennael: that's bad
20:26:22 <Xardas008> it should ever be up to date
20:26:34 <ennael> #action keep wiki up to date by mentors and trainees
20:26:50 <ennael> ok anything to add on this topic ?
20:26:56 <AL13N> ennael: about packaging lesson, IMHO that has more sense when we start 2nd wave mentoring (newbies)
20:27:12 <ennael> AL13N: yep
20:27:12 <shikamaru> ennael: I think we should have some links for reference
20:27:24 <Ruperto> yes one question
20:27:36 <shikamaru> I will post a list of useful pages on the ml
20:27:36 <Anssi> am I understanding correctly that we'll wait for the mentoring process to be written before granting any apprentice accounts?
20:27:37 <Xardas008> shikamaru: and better links than that one by ibm i posted on first meeting
20:27:40 <ennael> #info think about having packaging lessons on IRC later for very beginners
20:27:56 <Ruperto> after teaching, if i tell you that my padawan is ready, how do you know that he/she has the right skills
20:27:56 <ennael> Anssi: nope I don't think so as you already did it
20:28:09 <ennael> the point with this process is to help mentors achieving this
20:28:21 <Anssi> ennael: ah, ok
20:28:23 <shikamaru> ennael: it could be nice that the logs could be published so that mentors that aren’t available know what’s been done
20:28:36 <shikamaru> maybe we could use meetbot too
20:28:38 <ennael> which logs ?
20:28:42 <ennael> ahah :)
20:28:47 <shikamaru> for the IRC lessons
20:28:48 <ennael> we are using it ;)
20:28:48 <Xardas008> he means for the lessons
20:28:50 <ennael> ah
20:28:54 <ennael> yep sure
20:29:14 <ennael> mentoring process should also list all points to validate a trainee
20:29:18 <AL13N> we could make a wiki page with subscriptions, if there are more than 20, we can do it
20:29:34 <ennael> we had mentoring process in mdv but not very formal
20:29:58 <shikamaru> also trainees wannabes can also learn from that, will get the second wave sooner ready too :)
20:30:01 <brianb__> i think people who have shown an intrest in packaging who registered who are new - should be given some idea as when when they can be assigned a mentor otherwise people will just lose intrest with magei 1
20:30:27 <Anssi> Ruperto: we'll see if they make lots of mistakes in their commits :)
20:30:32 <shikamaru> brianb__: I would say, when it’s done
20:30:33 <Xardas008> brianb__: good point i'm fighting with that atm
20:30:37 <ennael> brianb__: you are right
20:30:42 <AL13N> Anssi: :-S
20:31:02 <shikamaru> it’s important not to rush things, some people learn more quickly than others, but we have to take the time
20:31:14 <Xardas008> but maybe in 2 weeks i have more time for packaging
20:31:16 <Ruperto> Anssi: i was expecting like a challenge task for a package, it is normal that one do mistakes but there could be mistakes that are built
20:31:17 <ennael> brianb__: we can describe how they can start learning packaging
20:31:38 <ennael> they are quite a lot of things to read before starting
20:32:00 <ennael> then use mentoring irc chan to ask for questions
20:32:01 <Xardas008> ennael: it would be nice if there will be links provided for example packages on how someone can start (a few dependencies to none )
20:32:10 <ennael> yep
20:32:24 <Anssi> Ruperto: interesting idea which could be useful, but I'm not sure if it is really needed
20:32:29 <Xardas008> the mandriva one describes how to build a src rpm but without link to that package
20:32:29 <ennael> #info add a page to start learning packaging before applying for mentor
20:32:37 <baud> people willing to package, can follow #mageia-mentoring and review available doc', ask questions if it's not clear :)
20:32:52 <ennael> baud: it's not enough
20:32:53 <AL13N> in other words, our policies need to be finished with good examples
20:33:04 <ennael> there is tons of documentation everywhere
20:33:04 <Xardas008> AL13N: yes
20:33:18 <Xardas008> or just better links than the ones i found already
20:33:43 <AL13N> i vote for continuing this conversionation about 2nd wave mentoring when the policies are ready
20:33:45 <Xardas008> as you may know from mageia-mentoring channel
20:33:59 <ennael> ok can we switch to next topic ?
20:34:03 <AL13N> yes please
20:34:06 <Ruperto> yes
20:34:10 <Xardas008> sure if noone has something against that point
20:34:13 <baud> yep, ennael, will need to provide examples, like importing an existing spec from mdv (not too much work), import from fedora (a bit more work) or create from scratch...
20:34:27 <ennael> ok
20:34:41 <ennael> #topic review about build system status
20:34:58 <ennael> some words about mageia build system
20:35:15 <ennael> so basically all is nearly ready for packages submit
20:35:59 <ennael> import of packages started quite well
20:36:08 <ennael> about 1500 packages imported for now in svn
20:36:21 <ennael> submit is in progress for bootstrap
20:36:25 <Kharec> 1477 :)
20:36:30 <AL13N> http://pkgsubmit.mageia.org/
20:36:30 <erzulie> [ Mageia build system status ]
20:36:35 <ennael> wait please
20:36:44 <ennael> we are submitting packages for base system
20:36:51 <ennael> and low level stacks
20:37:04 <ennael> then we will be able to open submits in a larger way
20:37:18 <ennael> http://pkgsubmit.mageia.org/ can help you to follow progress
20:37:19 <erzulie> [ Mageia build system status ]
20:37:23 <Ruperto> ennael: low level stacks could be squid, snort?
20:37:38 <ennael> Ruperto: nope
20:37:39 <AL13N> Ruperto: no, gcc and coreutiles
20:37:40 <ennael> lower
20:37:59 <ennael> http://pkgsubmit.mageia.org/data/src.mdv.txt is the list of packages we need to build to achieve this step
20:38:07 <Ruperto> ok
20:38:30 <Motoko> So, basically get it to boot to an XDM session.
20:38:37 <ennael> about importing packages you will find quick doc here:
20:38:37 <ennael> http://mageia.org/wiki/doku.php?id=packaging#starting_package_import
20:38:38 <erzulie> [ packaging [Mageia temporary wiki] ]
20:38:53 <ennael> this is a very first howto that will be finalized soon
20:39:03 <ennael> but it gives you an idea of this process
20:39:44 <ennael> About first wave of packagers we have 40 accounts created for now
20:39:56 <doktor5000> the link lists dependecies of basesystem-minimal or even less?
20:40:11 <ennael> some more
20:40:21 <ennael> as you can see X for example
20:41:06 <blino> deps of basesystem + rpm-build
20:41:23 <doktor5000> blino: ok, thanks :)
20:41:24 <ennael> you can also follow build system progress here : http://mageia.org/wiki/doku.php?id=sysadmin#build_system
20:41:24 <erzulie> [ sysadmin [Mageia temporary wiki] ]
20:41:36 <ennael> main remaining steps (and bugs :) )
20:42:00 <ennael> any question on this ?
20:42:35 * ennael killed everybody :)
20:42:43 <Motoko> Looks good.
20:43:14 <Motoko> Please, continue.
20:43:29 <AL13N> no questions
20:43:41 <shikamaru> yep
20:43:43 <ennael> oh and finally we will start to setup build machine for isos
20:43:44 <Xardas008> not to that topi
20:43:45 <Xardas008> c
20:43:56 <sebsebseb> ISO building nice :)
20:44:04 <shikamaru> will we have a list for svn commits ?
20:44:13 <ennael> again alpha release will be very very alpha one
20:44:19 <ennael> shikamaru: yep
20:44:56 <ennael> you can also follow http://cia.vc/
20:44:57 <erzulie> [ CIA.vc ]
20:45:01 <shikamaru> ( I think it will be important to review changes for the mentoring process
20:45:13 <ennael> have a look on the most active project ;)
20:45:15 <AL13N> also #mageia-commits
20:45:33 <shikamaru> yep but importing adds a lot of commits and is difficult to follow on cia :)
20:45:42 <ennael> ;)
20:45:46 <ennael> ok next topic
20:46:05 <ennael> #topic relation with Mandriva Linux
20:46:16 <ennael> we add this topic as some people asked about this
20:46:31 <Ruperto> :-D
20:46:43 <ennael> we spoke a bit about this today
20:47:14 <ennael> conclusion was we have already a very heavy work on setting up mageia start
20:47:19 <ennael> and we cannot miss it
20:47:34 <ennael> we are already missing people on all pending tasks
20:47:50 <ennael> so what we propose is to add this on todo list and work on this a bit later
20:48:07 <sebsebseb> Whats this topic about? Working with Mandriva Linux, like helping each other at times or?
20:48:18 <doktor5000> #agreed
20:48:23 <ennael> sharing contributions and work
20:48:28 <ennael> when it can be done
20:48:37 <AL13N> is this just "relation to mdv" or more about packaging? ie: how to easily keep packages in sync for mdv AND mga?
20:48:44 <shikamaru> sebsebseb: I would think of a workflow to work on packages for both for instance
20:48:46 <doktor5000> first set up our own infrastructure before working with somebody else, no?
20:48:48 <shikamaru> yep AL13N :)
20:49:03 <sebsebseb> shikamaru: sure makes sense, sharing packages and other things that can be shared really, instead of something being done twice
20:49:08 <ennael> doktor5000: yep that's the proposal :)
20:49:24 <ennael> if everybody ok we can go to next topic
20:49:29 <AL13N> i agree with ennael: allthough...
20:49:39 <AL13N> some people have mdv and mga pacakges
20:49:43 <AL13N> if we change too much
20:49:46 <AL13N> it might not be easy to do
20:50:00 <AL13N> spec file, i mean
20:50:00 <ennael> ok
20:50:06 <AL13N> something to watch out for
20:50:07 <AL13N> imho
20:50:13 <ennael> next topic ?
20:50:16 <AL13N> ok
20:50:33 <sebsebseb> anyway yeah good for Mageia and Mandriva to work together at times, both will be part of the same distro family really
20:50:44 <shikamaru> ok
20:50:50 <ennael> #topic mageia policies: review
20:50:57 <ennael> shikamaru: your turn ? :)
20:51:02 <shikamaru> yep
20:51:04 <shikamaru> so,
20:51:20 <shikamaru> to summarize things a bit, some progress has been made on policies
20:52:42 <AL13N> but imho slowgoing, perhaps need more people to work on
20:52:57 <sebsebseb> Nice I just noticed the topic actsualley gets changed in the channel topic, when this.
20:53:07 <Kharec> Maybe more communications...
20:53:11 <AL13N> /o\
20:53:19 <shikamaru> some people are very active on the java policy, and there’s a lot of work in that area
20:53:19 <shikamaru> other policies have been imported
20:53:20 <shikamaru> some of them even reviewed
20:53:20 <shikamaru> but some of them have to be imported as well
20:53:20 <shikamaru> since we are starting mentoring, we need to finalize it
20:53:22 <gregorybravas> sip
20:53:40 <ennael> shikamaru: you can use whatever you want: ML, blog, irc... to ask for help
20:53:53 <Xardas008> i didn't have much time so i couldn't import much
20:54:14 <shikamaru> well, I started opening discussions on some policies, hoping it would get some more people to work on it
20:54:24 <Xardas008> and for the next 2 weeks i won't have much time
20:55:06 <shikamaru> but yes, I would have hoped more help from people who are experienced
20:55:14 <AL13N> well, "spec file syntax" and "how to package RPM" are 2 of the most important ones imho; and they need to be started on
20:55:30 <shikamaru> I will make a blog post about this, and ask on twitter too
20:55:32 <ennael> shikamaru: then do not hesitate to ping them directly
20:55:46 <shikamaru> yep in my mail I asked that
20:55:55 <shikamaru> jq reviewed the perl policy for instance
20:56:08 <ennael> shikamaru: I mean mail them or ping them personally
20:56:30 <shikamaru> ok
20:57:00 <AL13N> http://mageia.org/wiki/doku.php?id=policies-review
20:57:01 <erzulie> [ policies-review [Mageia temporary wiki] ]
20:57:23 <ennael> #info shikamaru will communicate on needs to finalize policies review
20:57:26 <shikamaru> I hesitate to ask because I know some of them are very busy on other tasks (tmb, misc, and boklm come to mind)
20:57:59 <ennael> shikamaru: I'm sure they will not kill you ;)
20:58:08 <shikamaru> :)
20:58:25 <ennael> anything to add ?
20:59:24 <shikamaru> well, less conversation, more action :)
20:59:33 <ennael> ok
20:59:37 <ennael> #topic organize maintainership for packages
20:59:55 <shikamaru> is it ok with the current process ?
21:00:03 <ennael> ?
21:00:05 <shikamaru> Anssi: Xardas008 do you have any ideas ?
21:00:26 <ennael> which process ?
21:00:33 <Xardas008> i think he means the policies
21:00:42 <shikamaru> for the policy review
21:00:57 <AL13N> policy looks good to me
21:00:58 <ennael> oh ok :)
21:01:03 <dorileo> shikamaru, I think the process is ok, just needs more attention and man power
21:01:15 <Xardas008> same point as dorileo
21:01:22 <Anssi> shikamaru: nope, looks ok
21:01:59 <shikamaru> ok so we can move on to the next topic
21:02:13 <ennael> so maintainership
21:02:17 <Kharec> yep
21:02:27 <ennael> we do not have for apps to manage it
21:02:51 <ennael> but as we have many volunteers we need to list it properly
21:03:01 <ennael> for now we have http://mageia.org/wiki/doku.php?id=packaging#list_of_categories
21:03:02 <erzulie> [ packaging [Mageia temporary wiki] ]
21:03:32 <ennael> basically first wave of packagers will keep maintaining packages they have on mdv
21:03:45 <Kharec> yeah
21:03:51 <Xardas008> mdv or mga ennael?
21:03:58 <ennael> mdv
21:04:03 <Ruperto> :-D
21:04:13 <Anssi> "they will keep maintaining packages they have on mdv on mga"
21:04:19 <ennael> thanks :)
21:04:26 <Anssi> duh, s/have/had/
21:04:30 <ennael> :)
21:04:32 <Xardas008> ok that sentence is more clear what's meant
21:04:36 <AL13N> Anssi: sometimes have
21:04:52 <Anssi> ah, right, many people plan to continue maintaining their mandriva pkgs
21:05:05 <ennael> so you were asking what beginners could do to avoid loosing interest in mageia
21:05:29 <ennael> they could choose some packages to work on and learn packaging
21:05:55 <Xardas008> give me a hint to find the package
21:05:58 <shikamaru> see http://maint.mandriva.com/listpkgs.php?owner=1
21:06:02 <ennael> you can ask on irc if you have doubts about difficulty of maintaining x or y package
21:06:07 <brianb__> how would they do that then?
21:06:24 <AL13N> send the proposed spec file to #mageia-mentoring
21:06:28 <ennael> http://maint.mandriva.com/listpkgs.php?owner=1 shows non maintained rpms
21:06:31 <AL13N> someone will look to see if it's good
21:06:33 <shikamaru> yep
21:06:48 <ennael> so you can have a look there to choose some packages
21:07:08 <Ruperto> ennael: when can we start importing your packages
21:07:20 <shikamaru> though not all of them are relevant (ie, maybe old stuff, unmaintained upstream)
21:07:21 <ennael> mine ? :)
21:07:35 <ennael> shikamaru: that's why asking on ML or irc can help
21:07:35 <baud> brianb__: rpmbuild -ba package.spec on mageia from a src.rpm of mdv, for example :) (or for the moment being, rebuild on 2010.2 from cooker like backporting...)
21:07:40 <shikamaru> yep
21:08:09 <ennael> is it clear or should we re explain?
21:08:14 <shikamaru> we could add that #info
21:08:17 <ennael> will send a email also to summarize
21:08:35 <ennael> #info choose packages on http://maint.mandriva.com/listpkgs.php?owner=1 to start learning packaging
21:08:50 <philippeM> and see if you understand the spec and feel that you can maintain it in the future
21:08:55 <AL13N> anyways, put your spec files in a pastebin and paste url on #mageia-mentoring, so people can see if you're on the right track
21:08:56 <ennael> #info ask on ML and/or IRC for help to choose proper packages
21:09:03 <baud> brianb__: is it more clear ?
21:09:33 <brianb__> not at present i will chat to you later about it ok
21:09:35 <Ruperto> and my question?
21:09:48 <ennael> Ruperto: ?
21:09:55 <shikamaru> Ruperto: you can if you have access to the svn
21:10:03 <ennael> ok
21:10:07 <shikamaru> what you can’t is submit packages
21:10:19 <shikamaru> because we have to wait for the basesystem to be ready
21:10:20 <Ruperto> ha ok, got it, just importing by now
21:10:25 <shikamaru> but
21:10:33 <shikamaru> please follow the import process
21:10:40 <Ruperto> yes of course
21:10:46 <gregorybravas> how can I request access?
21:10:53 <baud> brianb__: no souci, either on this chan or  #mageia-mentoring to let everybody follow :-) (and ask any questions)
21:11:01 <shikamaru> see http://mageia.org/wiki/doku.php?id=packaging#starting_package_import
21:11:03 <erzulie> [ packaging [Mageia temporary wiki] ]
21:11:46 <dmorgan> tmb: hey :)  don't import already imported packages :)
21:11:48 <shikamaru> is the twice import bug fixed ?
21:11:49 <ennael> anything to add ?
21:11:56 <ennael> :)
21:11:59 <tmb> dmorgan: what package ?
21:12:04 <dmorgan> tmb: gdk-pixbuf2.0
21:12:13 <dmorgan> tmb: it was already imported  + uploaded :)
21:12:34 <shikamaru> haha the timing is perfect :D
21:12:41 <shikamaru> I guess that answers my question :)
21:12:52 <tmb> dmorgan: sorry I made a typo when I checked svn :(
21:13:26 <tmb> dmorgan: but avahi complained about missing gdk-pixbuf2.0
21:13:38 <brianb__> is there any rule of thumb of how many packages any one person would be expected to maintine?
21:13:47 <ennael> brianb__: no rule
21:13:53 <shikamaru> brianb__: it depends
21:13:55 <AL13N> brianb__: some people manage 5, others 600+
21:13:58 <ennael> some have 3 or 4 and some 500
21:14:04 <ennael> just one rule
21:14:12 <ennael> maintain them properly :)
21:14:23 <ennael> so it depends on your skills and your time
21:14:24 <gregorybravas> ok :D
21:14:24 <AL13N> brianb__: you need to have time to handle all the bugreports for those and be in touch with the upstream
21:14:45 <baud> another one is being ready to keep them, more than 3 years :)
21:14:47 <dorileo> brianb__,  rule #1 keep in a good shape
21:14:49 <dorileo> :)
21:14:49 <dmorgan> tmb: yes i was looking avahi i don't understand why it fails yet :/
21:15:01 <dmorgan> tmb: no pb for the twice import, i just wanted to tell you :)
21:15:20 <ennael> dmorgan: stop please we need to finalize meeting :)
21:15:26 <ennael> so last topic
21:15:31 <dmorgan> ennael: sorry
21:15:44 * ennael does not want to sleep here :)
21:15:55 * Xardas008 already sleeping
21:16:00 <ennael> #topic Mageia in FOSDEM
21:16:14 * AL13N shakes Xardas008 wide awake
21:16:32 <ennael> so Mageia team will be in FOSDEM in Belgium
21:16:45 <ennael> 5 and 6th of februray
21:16:56 <ennael> we do not have booth for this first year
21:17:13 <Xardas008> booth?
21:17:16 <ennael> but we will have 2 slots for conference
21:17:20 <ennael> stand ?
21:17:24 <Xardas008> ah ok
21:17:26 <baud> Xardas008: a table :)
21:17:41 <ennael> so we will speak about mageia experience and first results
21:17:56 <doktor5000> small last question: spec/packages should be linted before import, yes?
21:18:15 <shikamaru> doktor5000: yes
21:18:28 <ennael> and meet some of you
21:18:43 <baud> ennael: no dedicated room either ? (apart in the hotel and restaurant)
21:18:46 <doktor5000> and errors are blocking and warnings not?
21:18:50 <AL13N> ennael: what are the 2 presentations on?
21:18:53 <Xardas008> i have no time (exams and birthday of my cousin)sry
21:18:58 <ennael> baud: nope as there is no more dedicated rooms for distros
21:19:03 <ennael> too many demands
21:19:03 <shikamaru> doktor5000: after the meeting please
21:19:27 <doktor5000> shikamaru: understood ;)
21:19:32 <ennael> baud: but we will find a place to have some meetings during these 2 days
21:19:35 <baud> ah, well as long as there's current to plug in the laptop
21:19:51 <ennael> baud: no way you will have to speak to real guys :)
21:20:11 <shikamaru> :)
21:20:13 <baud> (restaurant upstairs should be ok, it was calm last year)
21:20:24 <AL13N> ennael: what are the 2 presentations on?
21:20:27 <baud> hmmm aren't people real on irc ?
21:20:51 * ennael slaps AL13N
21:20:51 <ennael> 22:16 < ennael> so we will speak about mageia experience and first results
21:20:53 <ennael> :)
21:21:11 <shikamaru> people who will attend can add themselves to the list here: http://mageia.org/wiki/doku.php?id=events:fosdem2011
21:21:14 <ennael> people are quite curious about how this fork is handled and organized
21:21:15 <erzulie> [ events:fosdem2011 [Mageia temporary wiki] ]
21:21:38 <baud> ah beer event is confirmed http://fosdem.org/2011/beerevent \o/
21:21:38 <erzulie> [ FOSDEM Beer Event | fosdem.org ]
21:21:42 <ennael> any question on that topic ?
21:21:43 <AL13N> ennael: i just found your explanation vague-ish
21:21:56 <ennael> AL13N: we are writting it at the moment :)
21:22:16 <AL13N> should i bring laptop?
21:22:18 <shikamaru> mmh well
21:22:31 <ennael> any other topics, question ?
21:22:33 <shikamaru> I remember last year we had quite a hard time finding a restaurant
21:22:44 <ennael> shikamaru: I will book it in advance
21:22:44 <shikamaru> and ended up splitting the group
21:22:49 <shikamaru> cool :)
21:22:57 <ennael> that's why I asked people to register on wiki
21:23:05 <AL13N> shikamaru: please register on wiki for restaurant
21:23:12 <shikamaru> AL13N: I did
21:23:17 <AL13N> ok
21:23:19 <tmb> just FYI: if anyone need a SRPM before rpm5 was introduced on cooker, you can get it here:
21:23:20 <tmb> http://tmb.mine.nu/Mageia/Cauldron/mdv-SRPMS-pre-rpm5/
21:23:20 <erzulie> [ Index of /Mageia/Cauldron/mdv-SRPMS-pre-rpm5 ]
21:23:29 <brianb__> why are people curious about how the fork is handled ?
21:23:48 <ennael> brianb__: because distro is quite a huge project
21:23:55 <shikamaru> tmb: nice !
21:23:57 <shikamaru> ty
21:24:01 <ennael> how do we handle a community without company
21:24:13 <ennael> how we take decisions...
21:24:38 <ennael> ok can we say that meeting is over ?
21:24:55 <ennael> brianb__: we can speak about it just after meeting :)
21:25:12 <shikamaru> ok
21:25:15 <brianb__> ok thanks
21:25:25 <farfouille> thanks
21:25:28 <ennael> #endmeeting