20:02:25 <ennael> #startmeeting
20:02:25 <Inigo_Montoya> Meeting started Wed Jan  5 20:02:25 2011 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:25 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:02:25 <erzulie> [ MeetBot - Debian Wiki ]
20:02:36 <ennael> #chair ennael misc
20:02:36 <Inigo_Montoya> Current chairs: ennael misc
20:02:39 <ennael> hi all
20:02:42 <Kharec> hi
20:02:44 <farfouille> hi
20:02:44 <chrisellis> hi
20:02:47 <sebsebseb> hi
20:02:49 <Xardas008> hi
20:02:54 <brianb__> hi
20:03:06 <Renaud_Michel> hi
20:03:12 <ennael> so again happy new year 2011 and many good things for Mageia :)
20:03:21 <sebsebseb> brianb__: chrisellis Oh your here for the packaging meeting?
20:03:24 <Kharec> happy new year to all mageia's contributors :) again :)
20:03:33 <shikamaru> hi
20:03:40 <chrisellis> seb: yes
20:03:55 <sebsebseb> yeah I hope Mageia people had a nice Christmas (that celebrate it) and  New Years :)
20:04:28 <Xardas008> from me also happy new year
20:04:43 <chrisellis> from me too, happy new year all
20:05:03 <Motoko> Happy holidays to you all. Now, shouldn't there be a meeting?
20:05:12 <Kharec> sq:)
20:05:19 <ennael> ok so let's try to make it in 1/2h :)
20:05:25 <Xardas008> Motoko: there is now
20:05:43 <brianb__> seb: yes and happy new year to mageia people - let the Mageia magic begin!
20:05:54 <ennael> #topic starting importing packages
20:06:07 <ennael> ok so quick picture of build system
20:06:10 <sebsebseb> 2011 the year of the first Mageia releases! :)
20:06:24 <ennael> still in progress but now packages can be imported in svn
20:06:31 <shikamaru> great !
20:06:35 <Kharec> great new!
20:06:47 <ennael> so we will start with people who have already mdv account as planned in last meeting
20:06:49 <Xardas008> who will get the possibility to import them?
20:06:55 <Xardas008> ok
20:06:57 <Kharec> ennael: all packagers?
20:07:09 <ennael> I've done a list and will mail all people concerned
20:07:16 <Kharec> ok :)
20:07:24 <ennael> we have for now nearly 40 packagers which is nice
20:07:45 <Kharec> Which they are on the wiki?
20:07:46 <Nanar> including all or just mdv's one ?
20:07:50 <Xardas008> 40 packagers with mdv account?
20:07:50 <ennael> so for those people the point is to start import and take opportunity to sort packages
20:08:01 <ennael> clean old one and update it
20:08:04 <ennael> Nanar: mdv one
20:08:11 <Kharec> very good
20:08:20 <shikamaru> is there a viewvc interface to see what’s already done ?
20:08:20 <Xardas008> nice
20:08:27 <Nanar> there is a big work to do around rpm
20:08:29 <ennael> shikamaru: not for now
20:08:39 <ennael> wait please :)
20:08:41 <shikamaru> ennael: ok I’ll just svn ls then :)
20:08:47 <pterjan> Nanar: the small one would be nice
20:08:54 <ennael> 3 steps for these packagers
20:09:02 <ennael> create account in identity.mageia.org
20:09:09 <misc> (once it work)
20:09:10 <ennael> send ssh public key
20:09:16 <ennael> and then start import
20:09:21 <ennael> will send it in mail
20:09:40 <ennael> is that ok ?
20:09:44 <Kharec> yeah :)
20:09:47 <Xardas008> sure
20:10:08 <Nanar> pterjan: just to do s/mdv/mga/ ... a lot of side effect will appear
20:10:09 <shikamaru> yep
20:10:18 <ennael> ok
20:10:24 <ennael> second point now
20:10:32 <ennael> #topic start mentoring
20:10:38 <shikamaru> ennael: what about maintainership of the packages ?
20:10:45 <shikamaru> ah sorry, will ask later then
20:11:05 <ennael> you will be maintainer for packages you import :)
20:11:16 <Kharec> ok :)
20:11:20 <shikamaru> ok
20:11:45 <ennael> so about mentoring, it's important to start with so that we can increase packagers team
20:12:13 <Kharec> It need time and experience
20:12:35 <Kharec> So not all of packagers can mantoring
20:12:45 <mikala> ennael: did you start to assign packagers ?
20:12:49 <ennael> nope
20:12:50 <shikamaru> last meeting I attended people introduced themselves, now is there a list of people who should be mentored first ?
20:13:05 <ennael> shikamaru: we can have a look on wiki page
20:13:30 <ennael> we have some packagers who already did rpms or were part of mandrivausers.de or blogdrake
20:13:34 <brianb__> what bout the people who missed the last meeting - who are on the list?
20:13:35 <ennael> they could be the first one
20:14:17 <shikamaru> I agree
20:14:29 <Xardas008> there's nothing against
20:14:35 <ennael> if it's ok I will list them just after meeting and send list on ML
20:14:37 <Xardas008> iz
20:14:40 <Kharec> I agree too.
20:15:06 <Xardas008> what about the #mageia-beginning channel mentioned in last meeting?
20:15:30 <Xardas008> it it/will it be created?
20:15:35 <Xardas008> is*
20:15:43 <ennael> yep just have to remember the exact name
20:15:47 <ennael> let me look for it
20:16:02 <mikala> ennael: are we going to have a wiki page with a list of a mentor and his padawan assignement ?
20:16:23 <mikala> or should simply the mentor add it to a specific wiki page ?
20:16:34 <ennael> yep as soon as they are all ok
20:16:57 <ennael> will add list of mentor in same mail so that people can check
20:17:42 <ennael> on same time very beginners could start also even if they are still not priorities
20:17:56 <ennael> learning bases of packaging can help to start woth
20:17:58 <ennael> with
20:18:32 <ennael> any question on that point ?
20:18:34 <Xardas008> i began reading but hadn't much time, i just created all steps until i had my ssl key
20:18:58 <Xardas008> maybe tomorrow i've a little bit time left for continuing on that
20:19:03 <shikamaru> mmh I think a dedicated channel would be very useful for that purpose
20:19:05 <Nanar> s/ssl/ssh/ I presume
20:19:13 <Motoko> No questions here. I'm just eager to start.
20:19:13 <shikamaru> be it IRC or ML
20:19:23 <mikala> i second shikamaru for a dedicated channel
20:19:44 <Xardas008> the dedicated channel was also mentioned on last meeting
20:19:54 <mikala> a ML is probably better because we can eventually use the archive faster.
20:19:56 <ennael> will give you the channel as soon as boklm is around
20:20:13 * Nanar note, another chan for Sophie
20:20:37 <brianb__> i need mentoring but once i understand the techniques invovled - i would be willing to mentor other people and produce documentation
20:20:41 <chrisellis> would a wiki/wiki page also be of use along with ML/IRC chan
20:21:01 <ennael> chrisellis: as soon as official wiki is ready
20:21:05 <Nanar> chrisellis: anyway, we'll have howto/policy pages on wiki
20:21:11 <ennael> priority is put on build system at the moment
20:21:23 <chrisellis> sure
20:21:24 <ennael> ok next topic ?
20:21:37 <Kharec> yep
20:21:39 <chrisellis> yes
20:21:45 <ennael> #topic Mageia policies
20:22:07 <ennael> shikamaru: can you give us a quick picture of work done ?
20:22:17 <shikamaru> ok
20:22:41 <shikamaru> at the moment, policies have been listed for review
20:22:56 <shikamaru> but very few have been proofread
20:23:47 <shikamaru> I think we need to do that quickly if we are to start mentoring in the following days
20:23:59 <misc> yup
20:24:08 <brianb__> is there any time scales set re policies?
20:24:09 <ennael> shikamaru: maybe you can ping mdv packagers on specific policies
20:24:11 <shikamaru> as far as I’m concerned I’ll work 100% on it while svn gets populated
20:24:46 <misc> well, asking why people do not review them could help to figure what is blocking
20:24:46 <shikamaru> yes, I will raise these topics in the ml
20:24:56 <Nanar> I have two request about policies
20:25:03 <misc> I am not sure people have understood what is needed to be reviewed
20:25:31 <ennael> so be more precise on work that have to be done ?
20:25:34 <Nanar> 1) can we have one days included in each policiy explanation about they are here (for exemple why libidification)
20:25:49 <Nanar> 2) can we think about a process to change it
20:26:00 <Xardas008> could we put a temporary page on wiki where all policies which needed to be imported are listed and where people are listed who work on them?
20:26:13 <Xardas008> as a table so we can see which ones are in work and which not
20:26:52 <Xardas008> atm i have to guess if someone already works on a policy or not
20:27:08 <Nanar> I mean 1) : explanation about Why policies each policy were set
20:27:14 <ennael> wait
20:27:23 <ennael> 2 people speaking  at same time
20:27:26 <ennael> hard to follow
20:27:39 <Nanar> jusr correcting mysel
20:27:40 <dorileo> Xardas008, will duplicate what has been on ML?
20:27:40 <Nanar> f
20:28:07 <shikamaru> Nanar: could you explain point 2 ?
20:28:08 <Xardas008> dorileo: sure but on ml nobody writes atm that he's working on a policy
20:28:09 <dorileo> Xardas008, people can tell on ML what they`re about to take
20:28:22 <dorileo> Xardas008, cause they`re not working
20:28:37 <ennael> shikamaru: can you give a process so that people know who is doing what ?
20:28:47 <brianb__> what about introducing a traffic light system re policies - red priorty, amba needs further work, green completed?
20:28:49 <Nanar> shikamaru: I remember old time at mdv when policies were set by employees and nobody were able to change it
20:28:59 <ennael> Nanar: wait please
20:29:21 <ennael> shikamaru: still around ? :)
20:29:31 <shikamaru> on my phone
20:29:37 <shikamaru> connection dropped
20:30:58 <ennael> ok so shikamaru can you send an email like a summary about policies, more precise on what has to be done and setup on wiki status on who is doing what ?
20:31:07 <shikamaru> ennael: I can't help but thinking we need some tool like mantis to monitor the progress
20:31:37 <shikamaru> but yeah a wiki page sounds sensible to be able to follow the progression
20:31:49 <misc> uness the tool review the policy, it will not be enough :)
20:31:50 <ennael> ok just to start with and avoid confusion
20:32:17 <brianb__> who sigins off the completed policy?
20:32:28 <ennael> then we need  to look for more people working on this
20:32:31 <shikamaru> I will send a mail for that
20:32:45 <ennael> ok
20:33:10 <Nanar> shikamaru: on mageia-dev@ ?
20:33:14 <ennael> Nanar: about explaining why we have a policy this can be added during this cleaning
20:33:15 <shikamaru> yep
20:33:31 <ennael> and on that particular point "old" packagers only can help
20:33:39 <brianb__> surely for QA purposes a policy should be signed off
20:33:39 <Nanar> you'll probably need explanation from old packager for some
20:33:48 <Nanar> for technical explanation
20:33:51 <pterjan> who is old ? /o\
20:33:56 <ennael> :)
20:34:03 <ennael> pterjan: don't speak about me !
20:34:43 <mikala> ennael: it's about wisdom for you :)
20:34:45 <ennael> then about policies evolution, delete or add new we need indeed to write a process
20:35:04 <ennael> Nanar: as you spoke about it can you work on a proposal ? :)
20:35:15 <Nanar> ennael: ok
20:35:37 <Nanar> ennael: I'll think about it and send proposals
20:35:46 <ennael> ok nice
20:35:57 <ennael> anything to add on policies ?
20:36:02 <brianb__> yeah
20:36:42 <brianb__> 1) and formal procedure should be adopted
20:37:06 <brianb__> 2) a QA signing off should take place
20:37:28 <Nanar> brianb__: let's speak about it later, on ML
20:37:33 <Xardas008> has someone looked through the policies i added on wiki?
20:37:36 <brianb__> 3) feedback re changes should be included
20:37:37 <misc> #action nanar to send proposal about policy change process
20:37:39 <Nanar> you'll be free to troll
20:39:03 <ennael> ok anything else to add ?
20:39:19 <misc> #action shikamaru send a mail to summarize the work, and what should be done precisely
20:39:31 <misc> #action shikamaru write a summary on wiki
20:40:06 <Xardas008> nothing to add
20:40:37 <ennael> ok
20:40:49 <ennael> any other topic?
20:40:51 <brianb__> is there any time scales re: policies, mentoring etc...
20:40:59 <Nanar> ennael: yes
20:41:06 <Nanar> shortly,
20:41:14 <misc> brianb__: mhh, depend on the people doing the job, I guess
20:41:25 <Nanar> some package have to be adapted before other: rpm, rpm-setup
20:41:33 <ennael> wait
20:41:35 <ennael> what is topic ?
20:41:44 <Nanar> this will probably have effect on gcc and co
20:41:45 <brianb__> i understand that but it give some visibility
20:42:09 <Nanar> do we have a roadmap about package to import first/modify before all others ?
20:42:28 <Nanar> does this need to be defined ?
20:42:41 <shikamaru> about policies
20:42:57 <shikamaru> I think we could set a goal
20:43:04 <Nanar> shikamaru: ennael ask for other topic
20:43:07 <shikamaru> by the end of next week
20:43:12 <ennael> again one topic at a time
20:43:21 <ennael> otherwise it's a mess :)
20:43:45 <shikamaru> sorry,due to the lag I get responses later :/
20:43:45 <misc> ok so 1) timeframe
20:44:10 <misc> no, we do not have time frame, and I think it would be better to express that in term of "requirement"
20:44:26 <misc> and that's up to people responsible for this to give this
20:44:36 <misc> brianb__: does that answer to your question ?
20:44:53 <brianb__> yes
20:45:18 <misc> ok so 2) order of the import ( Nanar )
20:45:28 <misc> yes, we need to import them in order
20:45:47 <ennael> import or submit ?
20:45:52 <misc> well, both
20:45:58 <Nanar> so I have to define order ?
20:45:58 <misc> but yes, submit
20:46:15 <misc> importing without submitting is just pushing the problem to tomorow :)
20:46:33 <ennael> yes but it allows to work on cleaning and updating
20:46:40 <ennael> btw tmb is working on all basesystem
20:46:51 <misc> #info tmb is working on basesystem
20:46:53 <ennael> and as he said in last founders meeting it's nearly done
20:47:06 <Nanar> ok so I'll see with him
20:47:07 <ennael> he spoke about 2 days more if I remember well
20:47:35 <mikala> how are we going to build first package ? starting from a bootstrap ?or directly from mdv's package ?
20:47:43 <dorileo> ennael, yeah tmb said 2 days :)
20:48:06 <misc> mikala: see with tmb
20:48:07 <mikala> (so using mdv repository to ensure buildrequires & more)
20:48:09 <Nanar> mikala: we'll see what happend
20:48:35 <Nanar> mikala: there's evil loop in the bootstrap
20:49:00 <ennael> ok we will ask tmb to write a mail and summarize what is done
20:49:06 <Kharec> good!
20:49:08 <rtp> Nanar: loop*s* iirc :/
20:49:31 <Nanar> rtp: you know, my anglais ! :)
20:49:33 <misc> #action ennael ask tmb to summarize the bootstrap process
20:49:41 <rtp> :)
20:50:43 <misc> anything to add on this meeting ?
20:51:10 <ennael> any question? comment ?
20:51:11 <Nanar> ennael: ? anything to add ?
20:51:17 <ennael> not on my side
20:51:46 <Nanar> whoo, the meeting end almost in time ?
20:52:03 <ennael> ok done for tonight :)
20:52:04 <Xardas008> not really i think xD
20:52:08 <ennael> #endmeeting