20:03:45 <ennael> #startmeeting
20:03:45 <Inigo_Montoya> Meeting started Wed Dec 22 20:03:45 2010 UTC.  The chair is ennael. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:45 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:03:46 <erzulie> [ MeetBot - Debian Wiki ]
20:03:51 <ennael> here we go
20:03:53 <ennael> hi all
20:03:59 <anaselli> hi
20:04:24 <AL13N> ennael: btw: misc might not make it
20:04:42 <ennael> ok we will try to do all in 1/2h ok ?
20:04:51 <AL13N> \o/
20:04:52 <Xardas008> ok, which topic?
20:04:54 <misc> well, i am here
20:05:03 <ennael> misc is everywhere
20:05:08 <dorileo> hi misc
20:05:10 <AL13N> misc: heh
20:05:13 <ennael> #topic registration on wiki
20:05:13 <misc> hi
20:05:35 <ennael> ok as you may have seen I've modified a bit packagers list so that we can add missing information
20:06:11 <ennael> would be nice if all of you could complete any missing items
20:06:43 <AL13N> http://www.mageia.org/wiki/doku.php?id=packaging
20:06:44 <erzulie> [ packaging [Mageia temporary wiki] ]
20:06:48 <ennael> thanks
20:07:12 <ennael> any comment on this ?
20:07:40 <ahmad78> ennael: you changed the list into a table?
20:08:06 <ennael> yep and added items as level / packaging and mentoring
20:08:20 <AL13N> important is the level of packaging skills so we know who to mentor first
20:08:33 <AL13N> and who can mentor
20:08:37 <Renaud_Michel> is the "Mentoring" column to propose mentoring, or ask for? (or maybe both)
20:08:40 <obgr_seneca> in mentoring, do you mean "need mentoring" or "can mentor"?
20:08:41 <misc> by mentoing, you mean "need mentoring", or "ok to mentor" ?
20:08:49 <misc> good, nice combo
20:08:50 <ennael> Renaud_Michel: you can add any information in it
20:08:51 <AL13N> lol
20:08:57 <ennael> interested in
20:09:00 <ennael> don't want to
20:09:02 <ennael> later
20:09:12 <AL13N> need
20:09:20 <ahmad78> my guess, is "Gonna mentor newcomers"
20:09:45 <AL13N> ahmad78: i'll help you with the newcomers a bit
20:10:05 <ahmad78> (I meant what the column in the table meant)
20:10:11 <ennael> ?
20:11:04 <anaselli> i understood that as ahmad78
20:11:08 <anaselli> did
20:11:26 <ahmad78> ennael: there's a mentoring column in the table in the wiki page
20:11:31 <ennael> ok got it
20:11:37 <ennael> indeed
20:11:51 <Xardas008> i think it means who wants to be a mentor
20:11:56 <Xardas008> or am i wrong ennael ?
20:12:03 <ennael> but you can also mention that you are interested but later because you are not advanced one
20:12:21 <anaselli> interested in mentoring you mean?
20:12:24 <obgr_seneca> just read, what ennael wrote 10 lines before
20:12:25 <AL13N> yes, it is for people who _can_ mentor others
20:12:55 <Xardas008> wouldn't it be better to name the column interested in mentoring?
20:13:02 <ennael> ok so again important to update it if it's not done already
20:13:14 <ennael> will update explanations above
20:13:36 <dorileo> ennael, great this may an action :)
20:13:38 <Xardas008> I updated everything without the last two columns because I don't know which package to package yet
20:13:54 <ennael> ok
20:14:06 <AL13N> I changed title of column
20:14:32 <ennael> ok
20:14:55 <Xardas008> ok this sounds clearer
20:14:56 <anaselli> hmm, but can mentor, means also that is able to...
20:15:34 <Renaud_Michel> then how about ading a column "need mentoring"?
20:15:35 <ahmad78> any mentor will have to be "approved" by the packaging team
20:15:40 <ennael> would like to
20:15:43 <anaselli> i believe there is people who is able, but can't for any othe reason...
20:15:48 <ahmad78> so, that won't be a problem, is what I mean
20:15:50 <AL13N> the idea is that we're short on packagers so the somewhat experienced need to be mentored asap so they can mentor the newbies
20:15:53 * dorileo suggests two columns m1(mentoring), m2(mentored)
20:16:07 <ennael> dorileo: table is big enough for now
20:16:27 <GregoryBravas> I am mandriva packager ¿I need modify this http://www.mageia.org/wiki/doku.php?id=packaging  ?
20:16:27 <erzulie> [ packaging [Mageia temporary wiki] ]
20:16:36 <dorileo> ennael, that`s the why I suggested the shortening(m1, m2) :)
20:16:39 <boklm> or maybe two tables ?
20:16:41 <AL13N> (in principal everyone needs mentoring, unless they are mdv packagers)
20:17:18 <misc> well, ok so who is volunteer to redo the table and gather feedback ?
20:17:26 <misc> ( because we will not do this the whole meeting )
20:17:38 <ennael> let start with current one
20:17:38 <AL13N> i already edited the table satisfactory for me
20:17:41 <dorileo> AL13N, this may change in few weeks once people get ready(after their mentor period)
20:17:45 <ennael> we can improve it later
20:17:47 <AL13N> if someone has ideas, i can do it
20:17:58 <AL13N> next topic?
20:18:06 <anaselli> agree, the point is to add our data there
20:18:10 <ennael> anyway this is temporary wiki so I guess it's not worth to spend time on it
20:18:20 <ennael> #topic packagers representatives
20:18:48 <anaselli> ennael: are you candidate? or i did misunderstood that?
20:18:49 <ennael> ok hot topic :)
20:19:01 <ennael> well I thought it was clear enough in mail :)
20:19:05 <Xardas008> when i remember correct, there are just 3 candidates?
20:19:06 <ennael> at least for start
20:19:12 * ennael pushes misc
20:19:22 <obgr_seneca> I would nominate ennael and misc
20:19:28 <misc> well, I didn't found the time to redact a candidacy bad enough to not be elected
20:19:42 <ennael> :)
20:19:46 <anaselli> ennael: sorry it was a busy week and i read mail... quiclly :)
20:19:56 <anaselli> quickly
20:19:56 <ennael> :)
20:20:18 <AL13N> i nominate ennael for team leaders and misc or Anssi as expert packager
20:20:28 <ennael> ok the only thing is to express opinion on ML
20:20:36 <anaselli> i nominate ennael as well
20:20:43 <ennael> as it will be used to take decision
20:20:53 <AL13N> ok
20:21:17 <ennael> then people who did not attend meeting can also participate
20:21:24 <misc> I think people didn't grasp the concept of "short meeting" :)
20:21:30 <ennael> :)
20:21:42 <anaselli> ennael: could we start a thread on mailing list with  [vote] as a topic?
20:21:44 <ennael> so misc you need to send an email also
20:22:31 <anaselli> misc are you a candidate?
20:22:31 <misc> we could use epoll
20:22:38 <ennael> yes why not
20:22:44 <misc> anaselli: well, everybody want me, i cannot say no to my fans
20:22:52 <AL13N> misc: you can
20:22:54 <AL13N> :-)
20:22:56 <misc> ( in fact I can say no to my fan, not to ennael )
20:22:57 <anaselli> misc: :p
20:23:09 <obgr_seneca> :P
20:23:18 <AL13N> who can set up epoll?
20:23:22 <Xardas008> I'll vote for misc
20:23:33 <misc> AL13N: already setup
20:23:41 <ahmad78> epoll needs an account in catdap, or just email address?
20:23:43 <ennael> misc: can you add new vote ?
20:23:43 <Xardas008> if he says no or yes doesn't matter
20:23:46 <misc> the question is "who is in charge of entering all email of packagers"
20:23:58 <ennael> misc: I have a list already
20:24:06 <ennael> extracted from wiki
20:24:07 <AL13N> misc: i can add them from the packaging list if needed
20:24:09 <obgr_seneca> Please let's see, who is candiate on the ML and vote on epoll and let's get on with the meeting?
20:24:17 <AL13N> yes
20:24:25 <AL13N> 6 minutes left
20:24:30 <ennael> ok we will post on ML about all this
20:24:30 <Xardas008> go on
20:24:44 <misc> #action ennael post on the ml about the vote ( epoll, etc )
20:24:49 <ennael> han
20:25:02 <anaselli> do we have to vote now or we have some days for the result?
20:25:03 <ennael> #topic packaging policies
20:25:27 <AL13N> misc: (are you chair? i donno if your #action works)
20:25:36 <ennael> #undo
20:25:36 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Topic object at 0x856636c>
20:25:37 <dorileo> anaselli, once not everybody here I guess we`ll take some days for voting
20:25:43 <ennael> #chair misc
20:25:43 <Inigo_Montoya> Current chairs: ennael misc
20:25:54 <misc> AL13N: #action work, yes
20:26:00 <ennael> raa
20:26:06 <ennael> #topic packaging policies
20:26:07 <misc> AL13N: #chair can only change topic
20:26:12 <ennael> ok let's  go
20:26:13 <AL13N> misc: ok
20:26:30 <ennael> work has started on policies
20:26:43 <ennael> shikamaru did a big work on this
20:26:53 <ennael> so we need now to get some more volunteers
20:27:00 <ennael> to review all this
20:27:38 <obgr_seneca> should be experienced packgers?
20:27:41 <Xardas008> i would if i have the time, but i have to do lots of work
20:27:45 <ennael> rather yes
20:28:03 <ennael> misc: can you try to ping mdv packagers that could do this
20:28:04 <misc> well, depend on the review, a newer packager will find stuff that are not clear too
20:28:24 <misc> ennael: mhh, I guess I could try to do it
20:28:24 <obgr_seneca> I could have a look into it over xmas, even if i'm only a community packager
20:28:34 <misc> ennael: but I fear that I may not convince much :)
20:28:56 <ennael> try :)
20:29:11 <misc> #action misc try to convince mdv packagers to help on review
20:29:15 <ennael> ok
20:29:28 <ennael> as misc said we may need also beginners to read it
20:29:38 <ennael> check if it's clear enough also
20:29:52 <dorileo> good point
20:30:03 <Xardas008> i will try to find a bit of time for that
20:30:22 <ennael> thanks
20:30:42 <ennael> #action find more beginners packagers to help on review
20:31:06 <ennael> anything else to add ?
20:31:28 <anaselli> ennael: maybe the very first people
20:31:32 <anaselli> colud be the one
20:31:37 <anaselli> who are mentored first
20:31:57 <AL13N> anaselli: i think table needs to be filled in first
20:32:02 <anaselli> if they understood that... they are probly clear
20:32:11 <dorileo> ennael, misc what`s the current status of build system?
20:32:20 <ennael> wait please :)
20:32:46 <anaselli> ennael: the review has to be done on our wiki?
20:32:52 <ennael> yep
20:32:56 <ennael> please check shikamaru mail
20:33:00 <ennael> all is inside
20:33:08 <anaselli> ok i can start reading, link are somewhere?
20:33:17 <dorileo> anaselli, ML
20:33:21 <Xardas008> all in the mail anaselli
20:33:34 <ennael> #topic short review of bs setup
20:33:39 <anaselli> great... i need to read all week mails first :/
20:33:45 <AL13N> https://mageia.org/pipermail/mageia-dev/20101216/001742.html
20:33:46 <erzulie> [ [Mageia-dev] Mageia policies ]
20:33:48 <ennael> misc: can you just give a quick picture ?
20:33:59 <misc> yes
20:34:28 <misc> we are still working on setting up youri, wich is the component in charge of uploading and checkingpackage
20:34:38 <misc> i think boklm and blino have started to import it
20:34:53 <misc> and that should be the last bit for compiling a rpm and sending
20:35:01 <anaselli> thanks AL13N
20:35:09 <misc> next step would be 1) creation of account 2) import of basic system
20:35:21 <misc> and 3) websoftware for managing maintainer
20:35:31 <misc> rda is working , as you may have seen , on this last point
20:35:49 <AL13N> misc: does point 1) need some automatisation for SSH keys?
20:35:50 <misc> something quick and dirty for starting, and later, something with a little bit more reflexion
20:35:59 <misc> AL13N: already done, just need to be tested
20:36:57 <misc> basically, when it will be ready, we will inform people, no fear :)
20:37:10 <ennael> any kind of planning for this?
20:37:10 <AL13N> misc: will holidays be slow for this?
20:37:35 <misc> and if you need more information, you should follow mageia-sysadm to see our commit ( requires to be fluent in bs deployment, or puppet )
20:37:47 <misc> ennael: last time I gave a planning, it was not respected, so no :)
20:38:03 <misc> ( and well, I think boklm may know more than me on this subject, I am just a messager )
20:38:15 <ennael> boklm: ?
20:38:19 <AL13N> misc: realistically speaking; definately not this year?
20:38:20 <misc> AL13N: I dunno what others planned, I am mostly on others task at the moment
20:39:59 <dorileo> once we don`t have a bs already we can keep working on policies while we wait for bs final setup
20:40:28 <ennael> yep
20:40:50 <ennael> I will try to provide a list of guys who will be mentored in very first time
20:40:54 <AL13N> is there still help required for cleaning svn or importing basic system?
20:41:18 <ennael> not for now
20:41:22 <dorileo> ennael, we can`t do so much with mentoring until we have the bs
20:41:37 <dorileo> so we wait ;)
20:41:42 <ennael> dorileo: just name mentors for each guys
20:42:00 <misc> dorileo: people do not need a build system to create rpm on their computer
20:42:06 <ennael> also what we can start is packaging help for very beginners
20:42:25 <ennael> maybe a dedicated chan and create ML as planned
20:42:29 <ennael> misc: can we do it now ?
20:43:29 <misc> ennael: chan, yes, dedicated ml, well, this would requires catdap or let people use the old and ugly version
20:43:43 <misc> I am ok as long as i can tell to someone else to answer to people complaining :)
20:43:50 <ennael> :)
20:43:59 <ennael> css has been improved a lot in svn
20:44:02 <misc> yup
20:44:07 <ennael> so if we can update taht should be enough
20:44:08 <misc> but svn is not deployed yet
20:44:43 <misc> well, I can try to see in 7 days, I may be busy in the coming days ( christmas, etc )
20:44:56 <ennael> ok
20:45:20 <Xardas008> i will try to work on rpm build learning doring christmas
20:45:25 <ennael> ok
20:45:26 <misc> ( in fact, it will take 5 minutes, just copy in the branch, no QA, no test  /o\ )
20:45:47 <ennael> misc: so you can do it today as meeting is nearly finished :)
20:45:57 <misc> ennael: ok
20:45:57 <ennael> will send an email to explain all this
20:46:00 <AL13N> if people have questions about spec files, they can ask me
20:46:20 <ennael> #action send an email for registration on catdap and ML
20:46:33 <ennael> misc: can you create irc chanel for beginners
20:46:51 <ennael> or maybe boklm
20:46:54 <AL13N> is this for beginners or packaging beginners?
20:47:01 <ennael> packaging beginners
20:47:03 <misc> ennael: let's say boklm :)
20:47:09 <AL13N> then i can subscribe to that
20:47:09 <ennael> ok
20:47:42 <ennael> #action create irc chan for beginners in packaging
20:48:03 <ennael> want to add any other topic, comment, question ?
20:48:10 <AL13N> not me
20:48:19 <saschas> non
20:48:31 <dorileo> no
20:48:35 <misc> nope
20:48:40 <ennael> ok
20:48:41 <Xardas008> no
20:48:47 <Renaud_Michel> no
20:49:05 <AL13N> next topic?
20:49:07 <ennael> we will not have meeting next week
20:49:19 <AL13N> oh one thing
20:49:25 <ennael> next one should be on 5th of january
20:49:28 <AL13N> the i18n-fr meeting is the same time
20:49:37 <ennael> wednesday ?
20:49:43 <AL13N> Jehane said some of the members might be packagers
20:49:48 <AL13N> i donno if this is a problem or not
20:49:58 <AL13N> but 5th is ok for me
20:49:59 <misc> AL13N: well, with 7 days a week, and several team, colision are inevitable
20:50:01 <ennael> let start as it for now and see if it's a pb
20:50:03 <Xardas008> listening on 2 meetings nice
20:50:07 <misc> ( just do the math )
20:50:21 <AL13N> sure, i'm just stating what i heard today
20:50:23 <obgr_seneca> shouldn't the local i18n teams adapt to the international time table instead of vice versa?
20:50:44 <misc> well, so far, no one complained, just people said that other may complain
20:50:48 <AL13N> obgr_seneca: language and location is not the same thing
20:50:50 <misc> so there is in fact nothing
20:50:57 <AL13N> misc: ok
20:50:59 <ennael> ok
20:51:22 <ennael> well guys have an happy christmas and happy new year's day
20:51:28 <Xardas008> same to you
20:51:33 <obgr_seneca> AL13N: with local i18n team I meant thelanguage team
20:51:46 <ennael> #endmeeting