18:41:04 <rda> #startmeeting
18:41:04 <Inigo_Montoya> Meeting started Wed Jan 12 18:41:04 2011 UTC.  The chair is rda. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:41:04 <Inigo_Montoya> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:41:17 <rda> #chair rda ofaurax leeloo dmorgan
18:41:17 <Inigo_Montoya> Current chairs: dmorgan leeloo ofaurax rda
18:41:36 <rda> #topic icon replacement
18:41:43 <rda> ofaurax: so ? :)
18:42:43 <ofaurax> so, I looked
18:43:05 <ofaurax> All the icons from mandriva are derivated from the same shapes
18:43:23 <ofaurax> you have basic shapes : a computer screen, a person, etc.
18:43:36 <ofaurax> there are combinated to make the mandriva icons
18:43:54 <ofaurax> so It's easy to find shapes to replace them
18:44:16 <ofaurax> for example, there is a KDE IM client that provide a person shape
18:44:39 <ofaurax> I ran the script, but it didn't found the mageia things
18:44:49 <rda> one thing at a time :)
18:44:57 <ofaurax> rda: do you know if we have access to start the icon remplacement ?
18:45:33 <ofaurax> however, we will have some work to do based on these new shapes
18:45:34 <tumbeliina> i made today some icons for my own use
18:45:54 <rda> ok, but that's work to rebuild these icons; can this be scripted in some way or would it fit in the timeframe we have?
18:46:06 <rda> ofaurax: what do you mean by "didn't found the mageia things" ?
18:46:46 <ofaurax> rda: the report from the script there is no mageia icon
18:47:02 <rda> ofaurax: of course, there is nothing new yet. that's the point.
18:47:29 <ofaurax> ha ok, I was thinking that they were copied as a starting thing
18:47:32 <rda> first thing was to know what needs to be replaced. second is to replace it. (so in between, need to find or create replacement)
18:48:00 <rda> ofaurax: no, the script just compares the old tree (mdv) versus the new one (mga). but as long as nothing new is provided, they are both equivalent
18:48:55 <ofaurax> ok
18:49:00 <rda> can we at least first agree on a default placeholder icon (a generic one that we can use to replace all problematic icons)?
18:49:19 <rda> ha, actually, that was decided last time:
18:49:24 <rda> "use KDE ? icon for dummy placeholder icon"
18:49:31 <rda> ok, so that part is done.
18:49:41 <ofaurax> yes
18:49:49 <ofaurax> we talked about KDE and gnome icons
18:49:49 <rda> we'll mass replace all icons that are left for replacement if we don't have the time in the end.
18:50:09 <rda> so, now, the thing is to make sure of the list of icons that _have to_ be replaced, and work on modules, one by one.
18:50:55 <ofaurax> ha ok, I was thinking that we need to replace them all :/
18:51:19 <rda> all modules that we do keep in /soft yes
18:51:47 <rda> modulo a patch from dmorgan, there are about 20 modules or so, with about 930 icons
18:52:16 <rda> but for instance, we could first work on rpmdrake, userdrake2 or control-center or desktop-common-data
18:52:52 <rda> rpmdrake has 28 icons
18:53:01 <rda> that big and small enough to bootstrap the process maybe
18:53:02 <ofaurax> I would advocate to work by shapes but that's perhaps to complicated
18:53:16 <ofaurax> for example, all icons, with a person shape in it
18:53:30 <ofaurax> idem for screens
18:53:41 <rda> hmmm there are not so many screens, mostly icons.
18:54:09 <rda> anyway, you need shapes in everything, so starting by one module can help build basic shapes met there, build icons with it, and start a repository of shapes and icons.
18:54:17 <rda> and at least one full module will be done, step by step.
18:55:36 <ofaurax> yes
18:55:47 <ofaurax> so, what is nexte step ?
18:55:56 <ofaurax> choosing the module ?
18:56:24 <rda> first step is to have someone to coordinate and drive the whole thing (I can't)
18:56:31 <rda> and to report to the team
18:56:37 <rda> and to council/founders/packagers
18:57:10 <rda> dmorgan would be best to drive it from the packagers point of view (providing icons to replace, taking new icons and moving them in)
18:57:30 <rda> as for artistic direction, that's open
18:57:53 <rda> second step is to have everyone agree on the process and what guidelines should be for icons (and that must be done quick)
18:58:26 <rda> third step is to select one module to start, and just do it.
18:58:42 <rda> these 3 can be done  right away, now if everyone is on page.
18:59:26 <ofaurax> do we really need guidelines for the 1st iteration ?
19:00:15 <rda> the urgence may say that, no. but so 1st iteration icons may have to be redone later (and everyone has to be ok with this)
19:01:03 <ofaurax> I see that there is not really people to agree on some guidelines
19:01:20 <ofaurax> we saw that on the ML about the logo
19:02:02 <rda> ofaurax: why? your guidelines are not "not agreed", they are pending right now.
19:02:09 <rda> it's not because it's quiet that it means "no" :)
19:02:22 <rda> but ok, so let's skep this guidelines step for the time being.
19:02:59 <rda> ofaurax: so, you would like to drive the effort to try?
19:03:01 <ofaurax> yes, I understand, but as we are in a hurry, we can't manage pending  guidelines for the icons
19:03:25 <ofaurax> yes, I can manage the effort if you want
19:03:34 <ofaurax> I never done that, let's give it a try
19:03:53 <tumbeliina> http://www.flickr.com/photos/43658233@N06/5349698356/in/photostream/
19:04:16 <tumbeliina> i made that kind of icons and if needed i can do more samekind
19:04:40 <rda> ofaurax: ok, so you need to choose for a module to start and coordinate with dmorgan
19:04:47 <rda> I'd suggest rpmdrake but it's up to you really
19:05:09 <rda> ofaurax: and you should invite/coordinate other graphists in this team :-p
19:05:27 <ofaurax> tumbeliina: I think they are not easily distinguishable
19:05:35 <ofaurax> rda: I don't know anyone :(
19:05:53 <rda> tumbeliina: I'm not sure I see the point here?
19:05:59 <ofaurax> so; perhaps I should clarify the process
19:06:02 <rda> ofaurax: ping alexn83 and pinheiro maybe?
19:06:16 <rda> ofaurax: yep, make a proposal on the mailing-list
19:06:35 <rda> #action ofaurax takes on the coordination/production for the icons replacement
19:06:49 <rda> #action ofaurax sees if others can join the effort
19:06:52 <ofaurax> rda: ok, and I ask explicitly who wants to contribute, to be sure that everyone is awake
19:06:56 <rda> yep
19:06:58 <tumbeliina> rda, i made thouse for my own use, but if we need/want more i can do more
19:07:04 <rda> ofaurax: what module would you like to start with?
19:07:17 <rda> (you have the list of modules in the checkout of the script, if you did it)
19:07:30 <ofaurax> #action ofaurax establish remplacement process (what to do, what NOT to do, etc.)
19:07:52 <ofaurax> rda: i don't care
19:07:59 <ofaurax> perhaps one that is very used
19:08:04 <ofaurax> rpmdrake or drakx
19:08:22 <ofaurax> what is the name of the installer ?
19:09:11 <ofaurax> we need to start with the installer (people will see at install that this not mandriva), and most used tool (I would say mcc)
19:09:17 <rda> not sure it's in this list already, but it should
19:09:33 <rda> ofaurax: rpmdrake (28) or desktop-common-data (376) :-)
19:10:08 <ofaurax> rpmdrake doesn't show much icons
19:11:16 <rda> no, but precisely, that would be a quick start with a module totally done.
19:11:33 <rda> (+ the ability with the packager to rename the icons or move them to a theme-capable scheme)
19:12:12 <ofaurax> I had a look and these icons are used for menus
19:12:23 <ofaurax> (desktop-common-data)
19:12:49 <rda> yep
19:13:11 <ofaurax> I think that perhaps these icons must be defined with some marcom guidelines
19:13:17 <rda> forget about the theme thing, we'll dig in this later on the packager side
19:13:35 <rda> ofaurax: all actually. so that's the samae point, do we make guidelines now or not.
19:13:42 <ofaurax> ok, so we can start with it
19:13:59 <ofaurax> ok, so we can agree that :
19:14:02 <ofaurax> 1) no guidelines
19:14:12 <ofaurax> 2) start with desktop-common-data
19:14:29 <ofaurax> rda: is it ok for you ?
19:15:26 <rda> ofaurax: ok with me, but bear in mind that this is a lot of icons to start with
19:15:51 <dmorgan> hi
19:15:57 <dmorgan> sorry for my late :)
19:16:13 <ofaurax> dmorgan: do you prefer to start with icons from rpmdrake or desktop-common-data ?
19:16:56 <dmorgan> ofaurax: i would prefer desktop-common-data, i saw with ahmad who clean this package
19:17:05 <ofaurax> ok
19:17:25 <dmorgan> ofaurax: this package is from what he told me needed for mageia menu and contains some profile.d files important
19:17:41 <rda> #info first module will be desktop-common-data (ahmad cleaning it)
19:18:08 <ofaurax> #agreed we don't search have guidelines for 1st iteration of icon remplacement
19:18:10 <rda> dmorgan: can you set a discussion (email, irc, whatever) between you two and ahmad (and others participating on the artwork side) to work on this?
19:18:12 <ofaurax> oups
19:18:28 <rda> ?
19:18:31 <ofaurax> how do we delete ?
19:19:19 * ofaurax wants to delete its last #agreed message
19:20:15 <rda> #undo
19:20:15 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Agreed object at 0x869c12c>
19:20:17 <rda> :)
19:20:20 <ofaurax> ok, thanks
19:20:33 <ofaurax> #agreed we don't have guidelines for 1st iteration of icon remplacement
19:20:54 <ofaurax> so ok, for that
19:21:40 <rda> ok, so, do you need something else to start? ofaurax, dmorgan ?
19:21:41 <dmorgan> rda: yes yes i can :)
19:21:49 <ofaurax> rda: can you remind me what dmorgan and ahmad are doing now ? marketing, packaging ?
19:21:57 <rda> ofaurax: packaging
19:23:41 <ofaurax> rda: do I have access to mageia svn to replace the icon now ?
19:24:06 <rda> ofaurax: see that with dmorgan and ahmad I think
19:24:25 <ofaurax> ok, so we can move to the next topic ?
19:24:42 <rda> yep.
19:24:45 <rda> #topic logo
19:25:01 <rda> so, no update for now, I expected Caroline to post on the list
19:25:10 <ofaurax> so I sent a mail about the guidelines
19:25:13 <rda> yep
19:25:43 <ofaurax> I would like to be involved in the refinement, if able
19:26:21 <alexn83> My offer on logo drawing (a text part),
19:26:22 <alexn83> and a variant of wall-paper for alpha:
19:26:22 <alexn83> http://www.flickr.com/photos/54316230@N06/5327165735/
19:27:01 <rda> ofaurax: yep, that's why I wanted the prelimin. work to be posted and discussed on the list
19:27:01 <ofaurax> yes, that's nice
19:27:18 <rda> alexn83: looks nice, yes
19:27:33 <ofaurax> alexn83: you changed the bubble proportion and the font, no ?
19:28:06 <alexn83> only font
19:28:37 <tumbeliina> alexn83, nice :)
19:28:44 <ofaurax> alexn83: the bubbles border looks bolder
19:29:08 <rda> hmmm the font looks a bit more consistent with the logo
19:29:18 <rda> and the bubble over the i makes it consistent :)
19:29:34 <rda> actually, caroline proposal was, among other things, to fill in the bubbles
19:30:01 <DarkGuala> alexn83: nice+1 ;)
19:30:17 <ofaurax> isn't it the ubuntu font ?
19:30:20 <rda> and have a distinct color for bubbles
19:30:25 <rda> ofaurax: I was wondering that :)
19:30:52 <ofaurax> it doesn't seem to
19:31:22 <DarkGuala> ofaurax: http://artdriva.deviantart.com/gallery/#/d36v0k9 (sorry but is in Spanish) ;)
19:32:44 <ofaurax> ok, the logo is nice
19:33:17 <alexn83> fill bubbles - Good idea for small scale
19:33:18 <alexn83> no is drawing font
19:34:07 <ofaurax> alexn83: you made it from scratch ?
19:35:24 <ofaurax> so, perhaps we should be more consistent about the refinement process
19:35:49 <ofaurax> there is no much traffic on the ML, but we see proposal popping up during meetings
19:35:56 <alexn83> no, it's reworked Futura
19:36:17 <rda> ok, so.
19:36:30 <rda> #action alexn83 posts his refinement proposal on the list
19:36:36 <rda> #action caroline posts her refinement proposal on the list
19:36:43 <rda> #action anyone can do so
19:36:55 <rda> #action we discuss, rework, decide on these refinements
19:37:24 <ofaurax> ha ok, it is took from http://www.flickr.com/photos/54316230@N06/5142539028/
19:37:49 <ofaurax> Futura is opensource ?
19:38:33 <alexn83> no, but it's no futura
19:39:07 <rda> ok, so let's move a bit this discussion to the list, then, with actual proposals
19:39:11 <ofaurax> alexn83: do we have a complete opensource font for that ?
19:40:04 <ofaurax> ok, font is always to be decided
19:40:44 <ofaurax> for the record, the cauldron on the logo was based on the width of the border of the "e"
19:41:06 <ofaurax> so ok, next topic for me
19:42:03 <rda> ofaurax: yep, but we can also reconstruct the logo from that, separately. but that would not be needed right now
19:42:15 <alexn83> we ned complete opensource font for logo?
19:42:22 <rda> well, what other topic to discuss today?
19:42:26 <rda> alexn83: would be best, yes
19:42:40 <rda> but a free font can make it I guess
19:43:59 <alexn83> What for?
19:44:18 <rda> what for what?
19:44:57 <alexn83> What for we ned complete opensource font for logo?
19:45:19 <ofaurax> rda: as a side note, I had some never released tests with non-free fonts (that were better imho)
19:45:46 <ofaurax> alexn83: because we want to be able to make derivative works with paying for fonts
19:45:52 <rda> alexn83: be sure we are not constrained by some limitation to adapt to our need. that means: freedom or reuse, of course (mandatory). freedom of modification/redistribution would be nice, but again, that's not mandatory at this time.
19:46:21 <rda> still, there are gratis fonts that allow redistribution in fixed, non-vectorial forms.
19:46:28 <rda> we just need to make sure of this.
19:46:32 <ofaurax> alexn83: if the font is not free, everyone producing artwork with the font will have to pay for
19:47:16 <rda> ofaurax: careful. there are a lot of different provisions in use for fonts.
19:47:22 <ofaurax> however, mozilla uses non-free font, as a example
19:47:38 <rda> the font may not be free (fsf wise) but still allow gratis redistribution
19:47:58 <rda> ofaurax: but they are the exclusive user of this font, precisel
19:47:59 <rda> y
19:48:09 <ofaurax> rda: yes, I know. But with an opensource one, we don't have to worry
19:48:14 <rda> sure.
19:48:41 <rda> #action font licensing provisions to make clear for decision
19:48:44 <alexn83> это не шрифт, и не производная, это рисунок
19:48:47 <rda> ok, what else?
19:48:52 <rda> alexn83: ? :)
19:48:58 <ofaurax> rda : action for who ?
19:49:06 <rda> #undo
19:49:06 <Inigo_Montoya> Removing item from minutes: <MeetBot.items.Action object at 0x85c510c>
19:49:08 <alexn83> It not a font, and not the derivative, is drawing
19:49:16 <rda> #action font licensing provisions to make clear for decision (rda)
19:49:29 <rda> alexn83: indeed, yes
19:50:48 <ofaurax> do we switch to the logo derivative guidelines topic, now ?
19:53:26 <alexn83> Wait
19:53:26 <alexn83> About icons
19:53:43 <rda> alexn83: yes ?
19:53:49 <alexn83> Unfortunately I didn't have a possibility to work on holidays and I have made very little:
19:53:49 <alexn83> http://www.flickr.com/photos/54316230@N06/5349698826/
19:53:52 <rda> ofaurax: next, but quick, have a few minutes left only
19:54:26 <alexn83> Preliminary guide lines for icons are almost ready, it is necessary to add illustrations and to translate
19:54:27 <rda> alexn83: wow, very nice
19:54:42 <rda> alexn83: could you see with ofaurax then? (discussed earlier today)
19:56:19 <alexn83> I haven't time to translate :-)
19:56:36 <ofaurax> it is very good work
19:56:43 <rda> alexn83: I mean, later, here or by email :)
19:56:56 <rda> start a thread on the list about this, if it helps
19:57:05 <ofaurax> I dream of being able to do it from scratch myself
19:57:56 <rda> #topic logo/brand guidelines for derivative use (community or enterprise or university)
19:58:18 <rda> so, no easy/quick answer tonight, but the point to think about is the following
19:58:30 <rda> once mageia.org does release something under its own official name/brand/logo
19:58:36 <ofaurax> so, indepedently from the final refinement of the logo, we need to define what can be done or not
19:58:41 <rda> yep
19:58:52 <rda> community, entreprises, universities may use it to brand their own derivative version(s)
19:58:59 <ofaurax> yes
19:59:03 <rda> this has to respect and not infringe on the official mageia.org identity
19:59:26 <rda> still, provide a logical link and understanding that this is based on original mageia work _but_ is made by another entity
19:59:38 <rda> (I have a typical use-case from an enterprise point of view)
19:59:54 <rda> so... any idea already? :))
20:00:21 <ofaurax> rda: so, do we need guidelines on the logo derivations, or some derivation approved by us ?
20:00:49 * rda approved by us first.
20:00:53 <rda> always.
20:00:58 <ofaurax> if the purpose is to make derivative for local groups
20:01:02 <rda> but it's better to have already a list of rules to check against
20:01:09 <DarkGuala> boys, where you can locate the source (svg, xcf, *) of what they have to mageia (URL)? to try to help in tune with what we have done. ;)
20:01:15 <rda> and to have "derivative-ready" templates to
20:01:16 <rda> too
20:01:16 <ofaurax> we can for example propose a derivative based on a blank flag
20:01:37 <ofaurax> yes, that was my idea
20:01:39 <rda> DarkGuala: not sure I understood? :)
20:01:46 <rda> ofaurax: yep
20:04:19 <DarkGuala> rda: sorry, blame the google translator xDDD
20:04:22 <ofaurax> so, do we go further with the guidelines or do we drop them ?
20:04:22 <ofaurax> if we provide ourselves the derivative, no need for guidelines
20:05:00 <ofaurax> you need the SVG source ?
20:05:09 <rda> ofaurax: yes, we do need them, because: they will help us, they will help make it understandable by others, there may be uses of our official logo by third parties and they need guidelines
20:05:27 <rda> ofaurax: we have it. we'll publish a full section of the website about this (sources, guideliens, processes)
20:06:02 <ofaurax> ok
20:06:03 <rda> #action rda post the mailing-list about the derivative logo/brand use requirements and process
20:06:27 <rda> #info guidelines are important for public demonstration and reference of what is done internally to validate/derivate the brand
20:07:33 <ofaurax> perhaps people can react to the guidelines I proposed ?
20:09:50 <alexn83> The final variant of a logo is necessary to be based on it
20:11:22 <DarkGuala> I want to help but do not want to reinvent the wheel, so I need to know where to download the svg logo mageia or material already available, or tell me where I can help, here it is summer. ;)
20:11:58 <ofaurax> alexn83: no matter the final logo, the guidelines will adapt to it
20:12:17 <rda> ofaurax: I will
20:12:39 <ofaurax> DarkGuala: you want to propose a refinement ?
20:12:48 <rda> DarkGuala: ok, got it. :)
20:13:11 <rda> I suggest we get in sync about this on the list (I have to go now)
20:13:11 <ofaurax> rda: please manage the sending of the original logo, because I don't want to publish the SVG on the web for the moment
20:13:20 <rda> and we postpone other topics to next meeting (or to the list too)
20:13:21 <ofaurax> ok for me
20:13:28 <ofaurax> please use the list :)
20:13:28 <rda> ofaurax: yep
20:13:46 <rda> DarkGuala: are you on the mageia-artwork@ ml already?;
20:14:52 <rda> ok, closing the meeting. thanks everyone, and let's continue this discussion on the list. good evening to all!
20:15:01 <rda> #endmeeting